Problem build gcc 3.4.5 and Code::Blocks

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem build gcc 3.4.5 and Code::Blocks

frenchnkrazy
Everyone,

I have been using OpenCV under VisualStudio 6, 2005 and 2008 just
fine, and I'm trying to move to GCC (MinGW32) with Code::Blocks

I am getting a problem that I don't understand when compiling
highgui.dll :

C:\Program Files\OpenCV\otherlibs\highgui\cvcap_vfw.cpp:
In function `LRESULT FrameCallbackProc(HWND__*, VIDEOHDR*)':
error: `WM_CAP_FIRSTA' was not declared in this scope
error: `capSendMessage' was not declared in this scope
warning: unused variable 'WM_CAP_FIRSTA'
warning: unused variable 'capSendMessage'

All those are functions are declared in vfw.h, which is included at
start of cvcap_cfw.cpp

Of course used vfw.h comes from gcc

Have anyone seen this before ?

Thanks in advance

Crazy French Guy