Problem with libdc1394

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with libdc1394

sambit.bhattacharya
Hello,

When I try to run a sample program e.g. facedetect I get the following error but the output is fine i.e. the camera output is visible with face tracking for this particular example:

libdc1394 error: Failed to initialize libdc1394

I am doing this on Ubuntu 9.10. The libdc1394 I installed is version 2, with the command: sudo apt-get install libdc1394-22-dev

OpenCV configure was able to find that version as shown in the output:
Video I/O ---------------------
    Use QuickTime / Mac OS X: no
    Use xine:                 no
    Use gstreamer:            no
    Use ffmpeg:               yes
    Use dc1394 & raw1394:     no
    Use dc1394_v2 & raw1394:  yes
    Use v4l:                  yes
    Use v4l2:                 yes
    Use unicap:               no

I am using the BumbleBee stereo vision camera from Point Grey.
Any help is highly appreciated.

Sambit.

Reply | Threaded
Open this post in threaded view
|

Re: Problem with libdc1394

Samuel Audet
Sambit wrote:
> I am using the BumbleBee stereo vision camera from Point Grey.
> Any help is highly appreciated.

highgui is very buggy, just use libdc1394 directly.. it's easy to use
and works well

Samuel

Reply | Threaded
Open this post in threaded view
|

Re: Problem with libdc1394

shah
This post has NOT been accepted by the mailing list yet.
In reply to this post by sambit.bhattacharya
Did you able to solve this prolem